'분류 전체보기'에 해당되는 글 1883건

DST Root CA X3 루트 인증서가 만료되었습니다

위와 같은 에러가 갑자기 나타나고 있나요?(2021/10/1 기준)

 

정상적으로 동작하고 있는 웹사이트에 접속해보니

 

ERR_CERT_DATE_INVALID

 

에러가 나타나고 있습니다

 

인증서의 date가 유효하지 않다고 나오는 오류입니다

 

 

실제로 인증서가 만료되었거나, 사용자의 PC에서 로컬 날짜 세팅이 잘못되었거나 하면 발생할수 있는 문제입니다

 

그런데 인증서도 만료가 되지 않았고, 사용자 PC의 로컬 시간도 아무런 문제가 없었죠

 

 

 

letsencrypt 의 ssl 인증서를 사용하고 계신가요?

 

저도 그렇습니다

 

letsencrypt에서 DST Root CA X3 루트 인증서의 만료일이 바로 2021/9/30일이었던터라

 

해당 오류가 발생하는 것입니다

 

 

https://letsencrypt.org/ko/docs/dst-root-ca-x3-expiration-september-2021/

 

DST Root CA X3 Expiration (September 2021) - Let's Encrypt

이 웹 페이지는 아직 번역되지 않았습니다. 여기 에 기여할 수 있습니다. 마지막 업데이트:May 7, 2021 | 모든 문서를 참조 On September 30 2021, there will be a small change in how older browsers and devices trust Let’s

letsencrypt.org

 

letencrypt의 루트 인증서 변경에 대해서는 이미 letsencrypt에 공지된 내용입니다

 

letencrypt에서 기존에 사용하던 루트인증서 DST Root CA X3 를 더이상 사용하지 않고

 

새로운 루트인증서 ISRG Root X1를 사용한다는 내용입니다

 

 

 

그런데 문제는 구형 기기를 사용하는 유저에게 발생합니다

 

아래의 지원범위를 벗어나는 플랫폼을 사용한다면 새로 바뀐 루트인증서가 존재하지 않아 인증서 관련한 오류가 발생합니다

 

 

Windows >= XP SP3 (assuming Automatic Root Certificate Update isn’t manually disabled)
macOS >= 10.12.1
iOS >= 10 (iOS 9 does not include it)
iPhone 5 and above can upgrade to iOS 10 and can thus trust ISRG Root X1
Android >= 7.1.1 (but Android >= 2.3.6 will work by default due to our special cross-sign)
Mozilla Firefox >= 50.0
Ubuntu >= xenial / 16.04 (with updates applied)
Debian >= jessie / 8 (with updates applied)
Java 8 >= 8u141
Java 7 >= 7u151
NSS >= 3.26

 

https://letsencrypt.org/docs/certificate-compatibility/

 

Certificate Compatibility - Let's Encrypt

Auf Deutsch ansehen Ver en español Voir en Français לעבור לעברית 日本語で表示する 한국어로 보기 Ver em Português (do brasil) Просмотреть на русском Visa på svenska 使用简体中文阅读本网页。 使用

letsencrypt.org

 

 

인증서의 호환성에 대한 상세내용은 위의 링크에서 확인가능합니다

 

 

가장 주요하게는

 

Android 7.1 미만 버전은 Let’s Encrypt가 발급한 인증서를 신뢰하는 목록에 포함하지 않아, letencrypt 인증서를 사용하고 있는 사이트에 접속에 문제가 발생합니다

 

그리고 윈도우PC 에서도 루트 인증서가 업데이트되지 않았다면 동일한 문제가 발생합니다

 

(윈도우7, 10 이용자에게도 발생합니다)

 

하지만 ISRG Root X1 루트인증서를 포함하고 있는 Firefox 최신 브라우저를 사용한다면 로컬 PC에 직접 인증서를 설치하지 않아도 접속 가능 합니다.

 

 

그렇지 않은 경우에는 윈도우를 최신 업데이트하여 최신의 루트인증서가 반영될수 있도록 해주세요

 

만약 그게 여의치 않은 환경이라면 루트 인증서를 직접 설치해주는 방법이 있습니다

 

 

https://letsencrypt.org/certificates/

 

Chain of Trust - Let's Encrypt

Auf Deutsch ansehen Ver en español Voir en Français לעבור לעברית 日本語で表示する 한국어로 보기 Просмотреть на русском Pročitaj na Srpskom Visa på svenska 使用简体中文阅读本网页。 使用正體中

letsencrypt.org

 

여기에서 이 두개의 파일을 다운받습니다

 

isrgrootx1.der

isrg-root-x1-cross-signed.der

 

그리고 아래의 스텝에 맞춰 두개의 인증서를 모두 설치해주시면 됩니다

 

 

 

그리고 재부팅을 하시면 ISRG Root X1 가 설치가 완료되어 무사히 해당 루트인증서로 서명된 웹사이트를 이용할수 있습니다.

 

Comment List

| 1 | 2 | 3 | 4 | ··· | 1883 |